HomeTechSmartphonesiOS 15 will not be compatible with the iPhone 6s and the...

iOS 15 will not be compatible with the iPhone 6s and the original iPhone SE

Follow us on

According to a second report, Apple’s mobile operating system iOS 15 will not be compatible with the iPhone 6s and the original iPhone SE.

As every year, in June, we expect to see the renewal of all operating systems that give life to Apple devices. And according to the latest information, iOS 15 would abandon support with the iPhone 6s and the original iPhone SE of 2016.

Updates for more than six years

French site iPhoneSoft states that devices with an A9 processor, namely the iPhone 6s, iPhone 6s Plus and iPhone SE (2016), will not be compatible with iOS 15. As for the iPad the publication estimates that iPadOS 15 will no longer support the iPad mini 4 (2015), iPad Air 2 (2014) and iPad 5 (2017) that mount A8, A8X and A9 processors respectively.

Thus, the oldest processors to see iOS 15 support will be the A10s, which puts the top of the list at the iPhone 7 and iPhone 7 Plus. It should be recalled that the iPhone 6s was introduced in 2015, so at the time of the official presentation of the operating system, in September, it will be exactly 6 years old. A certainly long-lived support especially if we consider that Apple will continue to provide security updates if necessary.

This is the second time we hear rumors of the support that iOS 15 will offer. In November last year the website The Verifier published the same information about the iPhone 6s and iPhone SE. Although as always we will have to wait for official confirmation during WWDC.

It is clear that Apple wants to offer as much support as possible to older devices. The truth is that being able to update a phone with the best operating systems every year for six years is rather rare. While waiting for official confirmation of compatibility we can imagine the list of new features that may arrive with iOS 15, there are many candidates.

Leave a Reply